Daktela - Microsoft 365 outage - Outlook and Teams down – Incident details
All systems operational
Microsoft 365 outage - Outlook and Teams down
Resolved
Partial outage
Started over 2 years agoLasted about 5 hours
Affected
3rd parties services (integrations)
Partial outage from 10:11 AM to 3:11 PM
Other 3rd party services
Partial outage from 10:11 AM to 3:11 PM
Updates
Resolved
Resolved
Microsoft 365 Status
Confirmed that the impacted services have recovered and remain stable. Microsoft is investigating some potential impacts on the Exchange Online Service.
Monitoring
Monitoring
The email service Outlook is inaccessible.
Other services including Teams and Xbox Live were also reported as not working.