Resolved
Calls quality degradation IN UK

Started
21. 3. 2022 at 10:44
Status
Resolved after about 2 hours

Impact

Degraded performance
Affected
Voice Services
UK Voice Services
  • Resolved
    21. 3. 2022 at 12:31

    We just resolved the issue!

  • Identified
    21. 3. 2022 at 10:44

    We are continuing to work on a fix for this incident.